据 MacRumors 报道,苹果已经共享了一份新的支持文档,该文档指出内核扩展(它称为“遗留系统扩展”)将与 macOS 的未来版本不兼容,因为它们“不如现代替代品安全或可靠”。

  “系统扩展是一类在后台运行以扩展 Mac 功能的软件。一些应用程序安装内核扩展,这是一种系统扩展,可以使用旧方法进行工作,但不如现代方法安全或可靠。你的 Mac 将它们标识为遗留系统扩展。”

苹果 macOS 10.15.4 正式版逐步放弃支持“遗留系统扩展”-风君子博客

  从本周发布的 macOS 10.15.4 正式版开始,现在将在第一次加载内核扩展时显示警告,并在该扩展继续使用时定期出现警告。用户在 Beta 测试期间开始注意到该警告。

  苹果表示,它开始通知开发人员 macOS Catalina 将是 2019 年最后一个完全支持内核扩展的 macOS,并补充说它一直在与开发人员合作以过渡其软件。尚未确定最终的过渡日期,但一些开发人员假设 macOS 10.16 中将弃用内核扩展。

  具有内核扩展的应用程序将继续在 macOS Catalina 中运行。

  支持文件写道:“通过剥离这些扩展,开发人员正在帮助 Mac 进一步现代化,提高其安全性和可靠性,并启用更加用户友好的软件分发方法。”

  受影响的应用程序之一是 Malwarebytes 杀毒软件,它表示“占支持案例总量的很大一部分”与新内核扩展警告有关。

  Malwarebytes 总监 Thomas Reed 表示,苹果拥有新的 EndpointSecurity 框架来替代内核扩展:“我们已经意识到了这一点,并且自去年下半年以来一直在努力替换我们的内核扩展。如果计划内核扩展部分或全部不再起作用,我们计划在 macOS 10.16 发行之前用 Apple 的新 EndpointSecurity 框架替换它。macOS 10.14(Mojave)和更早版本将继续支持内核扩展,但是一旦我们有可用的更新,macOS 10.15(及更高版本)将不再需要它。”